97国际

一机领航,向光而生 丨 97国际网络一机一网3.0秋季新品宣布会
预约直播
以AI为焦点,让资产可管可控,数据鲜活有用 丨 企业智能运维实践宣布会
预约直播
97国际·(中国区)集团官方网站
产品
< 返回主菜单
产品中心
产品
解决计划
< 返回主菜单
解决计划中心
行业
合作伙伴
返回主菜单
选择区域/语言
97国际·(中国区)集团官方网站
97国际·(中国区)集团官方网站

202697国际官网
用户体验调研

马上加入
97国际·(中国区)集团官方网站

您订阅的产品有更新,请实时查阅

审查详情
97国际·(中国区)集团官方网站 97国际·(中国区)集团官方网站

动态路由协议有哪些

动态路由协议运行于具有路由转发功效的三层装备中。运行动态路由协议的装备之间通过交流路由信息,来自动获取数据在网络中的传输路径,作用类似于地图导航。本文先容动态路由协议爆发的配景,常用动态路由协议的基本看法、特点以及应用场景。

  • 97国际·(中国区)集团官方网站

    宣布时间:2022-08-31

  • 97国际·(中国区)集团官方网站

    点击量:

  • 97国际·(中国区)集团官方网站

    点赞:

分享至

97国际·(中国区)集团官方网站
97国际·(中国区)集团官方网站
97国际·(中国区)集团官方网站

我想谈论

1 路由协议
1.1   什么是路由
路由器收到数据报文,审查报文目的地址并依据路由表将报文转发到下一个路由器。报文经由路由器多次转发后抵达目的主机,路由器的转发路径就组成了路由的路径信息。由此可知,路由就是指网络将数据报文从源地址传输到目的地址的路径,最优路径将会以路由条目的形式存储在路由表中。路由历程爆发在TCP/IP协议栈的网络层,将具有路由转发功效的网络装备统称为广义上的路由器,这些网络装备可以是路由器、三层交流机、防火墙等。
1.2   什么是路由表
路由器若是想要实现数据报文的转发,需要借助于路由表和转揭晓。路由器凭证路由表举行路径妄想,通过转揭晓执行数据报文转发。路由表是指路由器中存储的一张路由信息表,路由表中存储着种种路由协议盘算的路由信息。路由表中包括的要害项有目的地址、网络掩码、路由协议、管理距离、路由开销、下一跳IP地址以及转发接口。直连路由、静态路由和动态路由协议盘算出的路由会存储于路由表中。在路由表中选择出最优路由路径后,路由表会将激生路由下发到转揭晓中,当数据报文抵达路由器时,会通过查找转揭晓来举行数据报文的转发。
1.3   为什么需要动态路由协议
为实现路由转发功效,路由器通过静态路由设置和动态路由协议两种方法来获取路由路径并维护路由表。面向目今日益变换的网络结构,静态路由具有较大的局限性。
1.3.1  静态路由设置的局限性
静态路由设置是指通过网络管理员手工设置牢靠的路由信息,由此实现数据报文的转发。静态路由设置利便,但每当网络拓扑结构爆发转变,都需要重新手工设置其路由信息,不可自动顺应于网络的更迭。因此静态路由设置适用于网络拓扑结构简朴并且结构稳固的小型网络。静态路由设置的局限性如下所示:
●    设置和维护泯灭时间和人力资源。
●    随着网络的扩展,维护事情会变得重大。
●    设置历程容易泛起过失,特殊是关于一些大型且结构重大的网络。
●    若是网络中某个网段泛起过失,无法自顺应的变换路径,将导致包括该条路由路径上的数据报文转发蜕化。
1.3.2  动态路由协议
通过网络管理员设置静态路由会爆发重大的事情量,且后续维护事情也难以高效举行。为解决这个问题,动态路由协议应运而生。通过动态路由协议,路由器接纳邻人世交流路由或链路状态信息通告的方法学习远方的路由,并坚持动态更新。相比于静态路由设置,接纳动态路由协议天生路由表信息的方法具有如下几点优势:
●    网络管理员只需要对动态路由协议执行设置和维护事情即可,相比于静态设置,事情量大大镌汰。
●    当网络拓扑结构爆发变换时,动态路由协议会自顺应地更新路由表信息。
●    设置历程禁止易泛起过失。
●    网络中泛起链路故障时,动态路由协议将重新妄想蹊径,绕开蜕化的网络。

1.4   动态路由协议分类
常见的动态路由协议包括RIP、OSPF、IS-IS、BGP。
凭证作用规模分类:
●    IGP(Interior Gateway Protocol,内部网关协议):在一个AS(Autonomous System,自治系统)内运行的协议,包括RIP,OSPF和IS-IS。
●    EGP(Exterior Gateway Protocol,外部网关协议):在差别AS间运行的协议,有BGP。
图1-1    IGP和EGP的关系示意图97国际·(中国区)集团官方网站


凭证路由盘算算法分类:
●    距离矢量路由协议:协议包括BGP和RIP。
●    链路状态路由协议:协议包括OSPF和IS-IS。


2 常见的动态路由协议
2.1   RIP
在动态路由协议降生初期,装备主要使用RIP(Routing Information Protocol,路由信息协议)。RIP是一种单播路由协议,应用于IPv4网络。RIPng(RIP Next Generation,下一代RIP)是RIP的扩展,应用于IPv6网络,两者在原理实现以及功效上相似度较高。运行RIP的装备之间通过交流路由信息,自动获获得达远程网络的路由。
RIP作为一种距离矢量路由协议,通过UDP(端口520)报文举行路由信息的交流,RIPng的UDP端口号为521。RIP使用跳数(Hop Count)作为其怀抱的单位来权衡抵达目的网络的距离。该协议划定目今装备与直连网络的跳数为0,关于非直连网络,每经由一台路由装备跳数值加1,为限制收敛时间,RIP最多允许15跳。若大于15跳,则体现目的网络或主机不可达�;诖讼拗�,使得RIP在大型网络中不适用。
由于RIP协议的简朴易用,设置和维护事情量远低于OSPF和IS-IS,以是RIP路由协议在现实小型网络中仍有普遍应用,例如校园网以及结构简朴的地区性网络。

2.2   OSPF
OSPF(Open Shortest Path First,开放式最短路径优�。┦荌ETF组织开发的一个链路状态路由协议。现在针对IPv4协议使用的是OSPF Version 2(简称OSPFv2),OSPF Version 3(简称OSPFv3)是为了支持IPv6而对OSPF协议举行的扩展。
OSPF接纳SPF(Shortest Path First,最短路径)算法。通过LSA(Link State Advertisement,链路状态通告)来转载和传输链路状态信息,以此来形貌网络拓扑结构,并依据此网络拓扑结构天生SPT(Shortest Path Tree,最短路径树),由此盘算出抵达每一个目的地址的最短路径,并将该路径存储于路由表中。
OSPF具备如下特点:
●    网络拓扑结构变换时,路由器之间能够快速通告信息,并实现路由更新。
●    在SPF算法的作用下,路由器之间仅同步链路状态信息,然后天生路径,阻止路由环路的爆发。
●    OSPF支持将网络拓扑划分为多个区域,有助于缓解大规模网络的盘算压力。
●    将路由分为多种类型区别看待,支持无邪的控制战略。
●    支持等价路由。
●    支持报文认证,包管协议交互历程的清静。
●    支持以组播地址发送协议报文,可以阻止滋扰无关者和节约系统资源。
基于以上特点,OSPF普遍应用于规模适中的网络中,即最多可支持几百台路由器的网络,例如中小型企业的网络。

2.3   IS-IS
IS-IS(Intermediate System-to-Intermediate System,中心系统到中心系统)路由选择协议最初是为CLNP(Connectionless Network Service,无毗连网络服务)而设计。随着TCP/IP协议栈成为主流,IETF组织对IS-IS举行了修改,使其能够同时适用于TCP/IP和OSI双协议栈,刷新后的IS-IS称为Integrated IS-IS或Dual IS-IS。
IS-IS与OSPF一样,接纳SPF算法,凭证网络拓扑结构天生SPT,盘算出抵达目的地址的最短路径。为了支持大规模网络,IS-IS接纳两级的分层结构,并将一个大的路由域被划分为两个或者多个区域,划分的区域被分成Level-1和Level-2两类,SPF算法划分自力运行于Level-1和Level-2中。且凭证区域划分界说了三种路由器角色。
●    L1路由器:用于管理区域内的路由。
●    L2路由器:用于管理区域间的路由。
●    L1/L2路由器:同时属于Level-1和Level-2的路由器。
IS-IS组网分为Level-1和Level-2,如图3-1所示,各区域及响应装备间的关系如下:
●    统一区域内的装备交流信息的结点组成Level-1,区域内的所有装备都知道整个区域的网络拓扑结构,认真区域内的路由交流。恣意一个L1路由器与同区域内的L1路由器、L1/L2路由器形成Level-1邻人关系,维护目今所处Level-1的链路状态数据库。
●    L1/L2路由器是差别区域的界线装备,用于提供区域毗连,L1路由器必需通过L1/L2路由器才华毗连至其他区域。恣意一个L1/L2路由器可以与同区域的L1和L1/L2路由器形成Level-1邻人关系,也可以与同区域或其他区域的L1/L2路由器、L2路由器形成Level-2邻人关系。L1/L2路由器维护Level-1和Level-2两个链路状态数据库。
●    区域之间通过L2路由器相毗连,恣意一个L2路由器与同区域或其他区域的L2、L1/L2路由器形成Level-2邻人关系,维护目今所处Level-2的链路状态数据库。所有的L2路由器与L1/L2路由器一同组成路由域的主干网,认真差别区域间的通讯。
图2-1    IS-IS条理结构图

97国际·(中国区)集团官方网站


IS-IS具备OSPF特点的同时,在扩展性方面,通过路由器扩展网络路由支持能力,即接纳划分区域来结构两级条理化的网络拓扑结构,并在区域之间使用路由汇总来镌汰路由器的肩负。IS-IS普遍应用于大规模网络的互通。

2.4   BGP
为便于管理网络,网络被支解为多个AS。在早期的互联网中,AS间动态交流路由信息使用的是EGP(Exterior Gateway Protocol,外部网关协议),EGP是一种简朴的网络可达性协议,只适用于树状拓扑网络,无法知足日渐重大的网络管理需求,因此EGP最终被BGP(Border Gateway Protocol,界线网关协议)取代。BGP可以实现环路阻止和路由优选,在路由传输功效上更为高效,并提供了更好的扩展性。
BGP是一种在AS间自动交流无环路路由信息的动态路由协议。BGP履历了差别的生长阶段,早期宣布过三个版本,划分是BGP-1(RFC 1105)、BGP-2(RFC 1163)以及BGP-3(RFC 1267)。现在使用的版本BGP-4(RFC 4271)作为目今AS间的标准路由协议被普遍应用。
在每个AS内运行BGP协议并发送BGP报文的装备称为BGP Speaker(BGP讲话者)。相同AS内的BGP Speaker之间的邻人关系,称为IBGP(Internal BGP,内部界线网关协议)邻人,从IBGP邻人学习到的路由称为IBGP路由,IBGP用于完成路由信息在本AS内的过渡。差别AS间的BGP Speaker之间的邻人关系,称为EBGP(External BGP,外部界线网关协议)邻人,从EBGP邻人学习到的路由称为EBGP路由,EBGP用于完成差别AS间路由信息的交流。
动态路由协议之间的优先级顺序为EBGP高于IGP,而IGP又高于IBGP。
BGP协议的特征如下:
●    差别于RIP、OSPF、IS-IS等IGP着重于盘算路由,BGP重点在于在AS间选择最佳路由和控制路由的传输,适用于承载大规模路由的网络。
●    BGP使用TCP协议作为传输协议,通过TCP协议的可靠传输机制包管BGP传输的可靠性。
●    BGP作为距离矢量路由协议,将外地选取的最优路由传输给邻人路由器,阻止环路的爆发。
BGP是为处于差别AS间的路由器实现路由信息交流提供包管,但并不是所有情形都需要运行BGP。
需要使用BGP的情形如下:
●    BGP的应用场景如图3-2所示,当装备或主机需要同时毗连两个或者多个ISP(Internet Service Provider,互联网服务提供商)时,ISP需要向装备或主机提供完整或者部分Internet路由,此时,需要通过BGP来决议选择哪个ISP的AS来抵达目的地址更具经济性。
●    装备或主机之间需要传输AS间的路由。
●    装备或主机需要通过三层VPN传输私网路由。
●    装备或主机需要传输组播路由,结构组播拓扑。
图2-2    BGP应用场景图

97国际·(中国区)集团官方网站


不需要使用BGP的情形如下:
●    装备或主机只与一个ISP相连。
●    ISP不需要向装备或主机提供Internet路由。
●    AS间使用了缺省路由举行毗连。


3 总结
为实现差别网络间的数据报文转发,路由器、路由表以及路由协议缺一不可。在路由表中生涯着种种路由信息,用于指导路由器转发。动态路由协议用于盘算路由、学习路由,并将路由信息加入路由表。动态路由协议的爆发解决了静态路由设置的局限性,面临差别的网络场景,需要应用差别的动态路由协议,从而实现效益最大化。

相关推荐

家用路由器怎样设置

大型数据中心网络路由协议选择

大型数据中心BGP路由协议妄想

相关标签:

97国际·(中国区)集团官方网站 97国际·(中国区)集团官方网站

点赞

更多手艺博文

任何需要,请联系97国际

97国际·(中国区)集团官方网站

返回顶部

收起
97国际·(中国区)集团官方网站 文档AI助手
97国际·(中国区)集团官方网站 文档评价
资料内容是否对您有资助?
您对目今页面的知足度怎样?
不咋滴
很是好
您知足的缘故原由是(多�。�?
您对文档是否尚有其它的问题或建议?
为尽快解决问题,请您留下联系方法以便回复
邮箱
手机号
谢谢您的反�。�
97国际·(中国区)集团官方网站
97国际·(中国区)集团官方网站
97国际·(中国区)集团官方网站
请选择服务项目
关闭咨询页
售前咨询 售前咨询
售前咨询
售后服务 售后服务
售后服务
意见反响 意见反响
意见反响
更多联系方法
网站地图